Bem vindo ao brockdev.com, não seja tímido compartilhe suas duvidas e conhecimento. :D

Resolvendo Mcrypt PHP extension required

thiagothomaz Moderador Global
editado January 2014 em PHP
Olá pessoal. Essa dica que vou dar agora não é especifico do Magento (embora já vi esse problema na instalação dele uma vez).

Na instalação de vários CMS ou Frameworks acontece de aparecer o erro: Mcrypt PHP extension required.

Quando aparece esse erro é muito comum abrirmos o terminal e digitar: sudo apt-get install php5-mcrypt, aparecer o mensagem de instalado com sucesso ou o pacote já está instalado.

Então chamamos a função phpinfo(); a função mostra a extensão e nada do erro sumir.
O Fix para esse erro tem que ser feito manualmente:


sudo apt-get install php5-mcrypt
sudo ln -s /etc/php5/conf.d/mcrypt.ini /etc/php5/mods-available
sudo php5enmod mcrypt
sudo service apache2 restart


Esse é um bug comum no Ubuntu 13.10 pelo que notei.

Mais detalhes do bug: https://bugs.launchpad.net/ubuntu/+source/php-mcrypt/+bug/1241286
Thiago Thomaz
Arquiteto de Software
http://www.thiagothomaz.com

Comentários

Entre ou Registre-se para fazer um comentário.