Bem vindo ao brockdev.com, não seja tímido compartilhe suas duvidas e conhecimento. :D

Váriavel valor total do pedido ?

135

Comentários

  • sim ela esta lá no banco de dados



  • e novamente o erro tbm...

    The following errors were found :
    • Invalid checksum for file "ml/app/code/core/Mage/Core/Model/Layout/Update.php on line 444 2014-09-20T23:18:27+00:00 ERR (3): Warning: simplexml_load_string():/ing: simplexml_load_string(): Entity: line 2: parser error : XML declaration allowed only at the sta" : 43232 calculated, 0 expected
    • There was some error while unzipping the backup files
  • Abraao Marques Moderador Global
    Vi que o site voltou, o que era?
  • sim voltou não sei q houve fiz outro backup de uns dias atras, mas o item Pedidos não funciona quando clico ele abre uma url... http://www.mezzbrindes.com.br/index.php/admin/sales_order/index/key/84a3238c6b94ec7c0baf3fcd8f2ec180/

    e é o único, pq os demais itens do menu vendas funcionam(aparecem)
  • Abraao Marques Moderador Global
    Poxa, graças a Deus, você conseguiu voltar o site. Testei o pagamento e funcionou sem problemas.

    Eu já passei por isso, esse problema para abrir o pedido. Isso ocorreu quando os clientes compraram por um módulo que eu desabilitei. Certifique-se que os módulos que estavam funcionais, na data desse backup, estejam funcionais agora, também.

    Cara, outra coisa, faça uma cópia de toda a sua base de produção e passe essa cópia para o seu ambiente de teste. O ambiente de teste precisa ser fiel ao de produção, para evitar esses problemas na loja em produção, on-line.
  • Seguinte... os módulos que você falou... não sei se esse é o problema pq todos estão habilitados como estavam no mesmo dia do backup acredito eu...
  • erro log:

    2014-09-23T19:38:41+00:00 ERR (3): Warning: simplexml_load_string(): Entity: line 2: parser error : XML declaration allowed only at the start of the document  in /home/mezzbrin/public_html/app/code/core/Mage/Core/Model/Layout/Update.php on line 444
    2014-09-23T19:38:41+00:00 ERR (3): Warning: simplexml_load_string(): <?xml version="1.0"?>  in /home/mezzbrin/public_html/app/code/core/Mage/Core/Model/Layout/Update.php on line 444
    2014-09-23T19:38:41+00:00 ERR (3): Warning: simplexml_load_string():      ^  in /home/mezzbrin/public_html/app/code/core/Mage/Core/Model/Layout/Update.php on line 444

  • a linha 444 q se diz que tem erro é em app/code/core/Mage/Core/Model/Layout/Update.php
    $fileXml = simplexml_load_string($fileStr, $elementClass);
    no arquivo update.php
    2014-09-23T19:38:41+00:00 ERR (3): Warning: simplexml_load_string(): Entity: line 2: parser error : XML declaration allowed only at the start of the document  in /home/mezzbrin/public_html/app/code/core/Mage/Core/Model/Layout/Update.php on line 444

  • Abraao Marques Moderador Global
    Cara, eu darei uma pesquisada sobre isso. Assim que eu descobrir alguma coisa sobre esse erro, já posto aqui.
  • Abraao Marques Moderador Global
    Acessei agora, e está dando o erro:

    SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'admin_assert' already exists

    Possivelmente, no processo de dump, ele não atualizou esse tabela.

    Dá uma olhada nela.
  • Ok obrigado! :)

    Agora o site caiu ta fora do ar :(
    instalei o módulo ofcial do pagseguro, sendo que já tinha instalado na minha loja o módulo do pagseguro do bruno exclui os dois e depois instalei novamente somente o do bruno
    muito estranho afetar a tabela de pedidos, eu tinha feito o backup restaurei apartir dele mas parece que não há nenhuma mudança, muito estranho.




  • Abraao Marques Moderador Global
    Você já tinha utilizado o outro módulo para fazer pagamentos, também? Se houve pagamento com o módulo que você removeu, dará problema nos pedidos.
  • eu estava utilizando somente o do bruno.
    depois do nosso teste com  módulo oficial do pagseguro 2.2 eu instalei ele na loja nova onde só tinha oo módulo do bruno, mas isso deu pane e ralou tudo :(
  • entrei no cache e tinha isso..

    a:4:{s:4:"hash";i:2723407904;s:5:"mtime";i:1411561300;s:6:"expire";i:9999999999;s:4:"tags";a:1:{i:0;s:8:"f7a_MAGE";}}


  • que faço nesta tabela ?


  • Abraao Marques Moderador Global
    brunowd disse:

    eu estava utilizando somente o do bruno.

    depois do nosso teste com  módulo oficial do pagseguro 2.2 eu instalei ele na loja nova onde só tinha oo módulo do bruno, mas isso deu pane e ralou tudo :(
    Poxa...

    Tem que ser alguma outra coisa. Só isso que foi feito, uma pequena alteração num arquivo, não daria todo esse pane na sua loja. Tudo o que foi feito foi incluir uma concatenação de uma variável...
  • Abraao Marques Moderador Global
    Em qual servidor está a sua loja: apache ou nginx?
  • acho q apache

  • brunowdbrunowd Usuário
    editado September 2014
    Sim essa foi a única alteração agora o site caiu deu uma olhada www.mezzbrindes.com.br ?
    Meus chefes estão loucos cmg, muito mesmo medo o.O
  • Abraao Marques Moderador Global
    Para ganhar um tempo, pois imagino como você deve estar, por já ter passado por isso, tenta por uma página de "Site em Manutenção", por exemplo.

    Isso minimiza e te dá mais tempo para procurar a solução.
  • E como fazer isso, não tenho ideia sou muito novo no magento e tals.
    Na real eu estou restaurando um outro backup aqui vai demorar ainda está em 44% ele tem uns 780mb, e o mais estranho também é que quando restauro o backup ele não volta as configurações anteriores.
  • Fiz o backup não adiantou, mesmo erro
  • O servidor é em Sistema Linux, rodando apache e utilizando o ngix para optimizador de velocidade de servidor. 
  • Abraao Marques Moderador Global
    Cara, como você fez o dump? Você removeu todas as tabelas e depois fez o dump ou fez o dump sem remover as tabelas antes?

    O backup que substitui é apenas o banco ou banco + FTP?

    Outra coisa, depois que fez o dump, você removeu o cachê do Magento?
  • Dump? que isso kk o backup é banco de dados e ftp e removi o cache em var/cache
  • Abraao Marques Moderador Global
    Cara, isso é muito louco. Se você substituiu todos os arquivos do FTP e TODO o banco de dados, então não deveria voltar a funcionalidade.

    Continuo pesquisando sobre isso...
  • Sim obrigado Abraao, apavorado realmente :(
  • Abraao Marques Moderador Global
    Cara, print o erro que deu quando acessei agora: 983874350059
Entre ou Registre-se para fazer um comentário.