Bem vindo ao brockdev.com, não seja tímido compartilhe suas duvidas e conhecimento. :D

Váriavel valor total do pedido ?

245

Comentários

  • Abraao Marques Moderador Global
    Cara, dá um CTRL + Z no arquivo PaymentMethod.php para desfazer todas as alterações que fez. Depois, limpa o cachê do Magento, faça a reindexação dos índices e teste novamente.

    Posta o resultado aí para nós continuarmos a trabalhar no pagseguro, novamente.
  • Abraao Marques Moderador Global
    Aí, que módulo é esse do bruno arrasive?
  • É fiz tudo isso que você mencionou mas nada funcionou. Tem certeza que não é conflito com módulo?
    É esse:
  • Abraao Marques Moderador Global
    Não conhecia esse módulo. Já que ele é para pagseguro, possivelmente seja conflito mesmo.

    Desabilite o módulo:  Sistema --> Configuração --> Avançado --> Avançado.

    Depois que desabilitar, faça a reindexação dos índices e atualiza o cache do Magento. Feito isso, testa novamente.

    Se não der certo dessa maneira, você terá que remover esse módulo pelo magento connect (se você o instalou por ali) ou no braço mesmo. Mas, antes disso, faça um backup do FTP do seu site, cara.

    Testa e posta aí.


    Um abraço.
  • Fiz tudo isso e nada, removi na mão via ftp nada funcionou.. talvez no log?
  • brunowdbrunowd Usuário
    editado September 2014
    Realmente não funciona... será que dá pra tentar implementar o módulo o bruno assarisse ?
    Ainda aparece a url: 
  • Abraao Marques Moderador Global
    Removeu os arquivos desse módulo nos diretórios:

    app/code/local/ e app/etc/modules?
  • Abraao Marques Moderador Global
    Fiz um teste de compra na sua loja e, quando clico em finalizar não redireciona para a página em branco, mas aparece isso:

    Whoops, our bad...

    The page you requested was not found, and we have a fine guess why.
    • If you typed the URL directly, please make sure the spelling is correct.
    • If you clicked on a link to get here, the link is outdated.
    What can you do?
    Have no fear, help is near! There are many ways you can get back on track with Magento Store.
    • Go back to the previous page.
    • Use the search bar at the top of the page to search for your products.
    • Follow these links to get you back on track!
      Store Home | My Account




    Você limpou todo o cache do Magento depois que removeu o módulo?


  • brunowdbrunowd Usuário
    editado September 2014
    No app/code/local/  não havia esse módulo

    em app/etc/modules exclui o arquivo BrunoAssarisse_PagSeguro.xml


    no log a estes erros... parece que ele está tentando abrir vários arquivos pagseguro 

    2014-09-23T16:39:03+00:00 ERR (3): Warning: simplexml_load_string(): <?xml version="1.0"?>  in /home/mezzbrin/public_html/app/code/core/Mage/Core/Model/Layout/Update.php on line 444
    2014-09-23T16:39:03+00:00 ERR (3): Warning: simplexml_load_string():      ^  in /home/mezzbrin/public_html/app/code/core/Mage/Core/Model/Layout/Update.php on line 444
    2014-09-23T16:39:03+00:00 ERR (3): Warning: include(PagSeguroResources.php): failed to open stream: No such file or directory  in /home/mezzbrin/public_html/lib/Varien/Autoload.php on line 93
    2014-09-23T16:39:03+00:00 ERR (3): Warning: include(PagSeguroResources.php): failed to open stream: No such file or directory  in /home/mezzbrin/public_html/lib/Varien/Autoload.php on line 93
    2014-09-23T16:39:03+00:00 ERR (3): Warning: include(): Failed opening 'PagSeguroResources.php' for inclusion (include_path='/home/mezzbrin/public_html/app/code/local:/home/mezzbrin/public_html/app/code/community:/home/mezzbrin/public_html/app/code/core:/home/mezzbrin/public_html/lib:.:/usr/local/php55/lib/php')  in 
    8-}
  • Abraao Marques Moderador Global
    brunowd, eu fiz download do módulo do Bruno Assarisse. Esses são os diretórios dos arquivos que você deverá acessar para os remover:

    app/code/community/BrunoAssarisse
    app/design/adminhtml/default/default/template/brunoassarisse_pagseguro
    app/design/frontend/default/default/layout/brunoassarisse_pagseguro.xml
    app/design/frontend/default/default/template/brunoassarisse_pagseguro
    app/design/etc/modules/BrunoAssarisse_PagSeguro.xml


    Assim você está removendo todos os arquivos e diretórios desse módulo. Depois de fazer isso, limpe todo o cachê do Magento, faça a reindexação dos índices e testa novamente.

    Um abraço.
  • Fiz isso e nada :(
  • Por enquanto vou ter que deixar instalado o do bruno, pq nao vou conseguiur fazer venda e eu não faço ideia não tenho nenhuma noção pra descobrir o erro
  • Abraao Marques Moderador Global
    Cara, você tem algum ambiente que possa efetuar testes? Se tiver, cópia todos os arquivos + o banco de dados do seu ambiente de produção, loja on-line, e instala a cópia nele. Ali, você poderá mexer a vontade.
  • Abraao Marques Moderador Global
    Ou, então, faça o seguinte, instale uma nova instância do Magento, no ambiente de testes, mova todos os arquivos do ambiente de produção para ele, com exceção desse módulo aí do Bruno Assarisse que está conflitando com o módulo do pagseguro que você pegou no pagseguro. Ali, faça todos os testes que puder.
  • Abraao Marques Moderador Global
    brunowd disse:
    Nesse você tem instalado os dois módulos do pagseguro, brunoassarisse e o que fez download do pagseguro?
  • E como crio essa nova instancia?

  • Abraao Marques Moderador Global
    No ambiente de teste que você passou, http://mezzbrin.bravunet.com/mezzdesenvolvimento/index.php/, você já tem uma instância instalada. Então, não precisa de outra. Você terá que verificar as configurações dela.

    Veja o que há de diferente desse ambiente com o ambiente em que a loja está on-line: versão do php, servidor (versão do servidor), versão do mysql, módulos que tem instalado.

    O ideal é que o ambiente de teste seja idêntico, configurações e informações, ao servidor em que o site está on-line.
  • Acho q a unica diferença são os módulos...
    :(

  • brunowdbrunowd Usuário
    editado September 2014
    Agora não consigo acessar meus pedidos na loja pronta :( :( :(
  • Abraao Marques Moderador Global
    Fera, volta tudo, então.

    Você fez um backup da sua loja antes de fazer as modificações? Volta o backup, então.
  • Ter até tenho mas só do dia 21  T,T

    mas vou restaurar o backup igual, depois vou tentar instalar o modulo do bruno na versao teste pra ver se dá aulgum erro lá tbm
  • Pior que não funcionou igual...

    aparece o erro

    The following errors were found :
    • Invalid checksum for file "age/Core/Model/Layout/Update.php on line 444 2014-09-21T23:22:12+00:00 ERR (3): Warning: simplexml_load_string(): ^ in /home//d_string(): Entity: line 2: parser error : XML declaration allowed only at the start of the document" : 43087 calculated, 0 expected
    • There was some error while unzipping the backup files
  • Tentei novamente com o backup do dia 20 e não deu resultado tbm, cara que loucura !
  • Abraao Marques Moderador Global
    Fera, limpa todo o cachê dele. Isso só pode ser cache, já que você restaurou o backup.
  • sim fiz isso tanto no backend quanto por ftp e nada to apavorado aqui, sério.
  • restaurei outro backup deu o seguinte erro:

    The following errors were found :
    • Table 'core_cache' already exists
    e agora não consigo acessar o admin
  • Meu site saiu do ar !
  • brunowd disse:

    Olha lá

    brunowd disse:

    www.mezzbrindes.com.br

  • Abraao Marques Moderador Global
    Cara, que loucura essa!

    Acessei e vi o erro. Abra o arquivo 187728996640 na parte report e print a mensagem de erro aí

    Ao que parece, quando você restaurou um outro backup, ele não conseguiu criar a tabela 'core_cache'

    Veja se ela existe no seu banco de dados.
Entre ou Registre-se para fazer um comentário.