Bem vindo ao brockdev.com, não seja tímido compartilhe suas duvidas e conhecimento. :D

Não envia emails (nem pelo default nem pelo módulo SMTP Pro)

Fala galera!

Estou tendo problemas com o envio de email no Magento.

Ele não envia nenhum (nem de cadastro, nem transacional, nem de inscrição de newsletter, nem de nada)

Em "Endereço de email da loja" ja coloquei os emails validos.

Em Sistema>Configuração>Avançado>Sistema nas configurações do email, ja deixei com as configurações do HOST e nada.

Configurei o SMTP Pro, que envia o email de teste, porém os do magento não envia.

Coloquei até meu email pessoal e mesmo assim não funcionou.

Configurei o Outlook com as mesmas configurações do SMTP Pro e o mesmo envia.

Minha versão do Magento é 1.8.0.0

Alguém pode me ajudar?


Obrigado!

Comentários

  • Jonatan Machado Moderador Global, Administrador
    Olá
    Rode um outro sistema de email dentro do servidor para testes
    Arsenal Web Design.com
    Desenvolvimento de Lojas Virtuais
    Magento | Zend Framework | HTML5 | CSS3 | Blogs
    image
    E-mail: contato@brockdev.com
  • disse:

    Olá
    Rode um outro sistema de email dentro do servidor para testes

    Fala Jonatan, beleza?
    Ja rodei um script php de formulário de emails consegui enviar o formulário e receber o email.
    O servidor esta enviando corretamente.
    O problema esta no magento.
  • Jonatan Machado Moderador Global, Administrador
    Voce verificou os logs?
    Arsenal Web Design.com
    Desenvolvimento de Lojas Virtuais
    Magento | Zend Framework | HTML5 | CSS3 | Blogs
    image
    E-mail: contato@brockdev.com
  • disse:

    Voce verificou os logs?

    Eu vi os logs, mas sou meio leigo para le-los.
    Eu entrei no meu site, assinei a newsletter e apareceu a mensagem que foi enviado um email de confirmação para meu e-mail, mas ele não chega. Olha os logs:

    system.log:
    2014-08-19T00:03:43+00:00 ERR (3): Warning: getimagesize(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/differen/public_html/app/design/frontend/athlete/default/template/olegnax/widgets/banners/headerfooter.phtml on line 8
    2014-08-19T00:03:43+00:00 ERR (3): Warning: getimagesize(http://differenze.co...g/logistica.png): failed to open stream: no suitable wrapper could be found in /home/differen/public_html/app/design/frontend/athlete/default/template/olegnax/widgets/banners/headerfooter.phtml on line 8
    2014-08-19T00:03:43+00:00 ERR (3): Warning: getimagesize(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/differen/public_html/app/design/frontend/athlete/default/template/olegnax/slideshow/athlete.phtml on line 78
    2014-08-19T00:03:43+00:00 ERR (3): Warning: getimagesize(http://differenze.co...w/masculino.PNG): failed to open stream: no suitable wrapper could be found in /home/differen/public_html/app/design/frontend/athlete/default/template/olegnax/slideshow/athlete.phtml on line 78
    2014-08-19T00:03:43+00:00 ERR (3): Warning: getimagesize(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/differen/public_html/app/design/frontend/athlete/default/template/olegnax/slideshow/athlete.phtml on line 74
    2014-08-19T00:03:43+00:00 ERR (3): Warning: getimagesize(http://differenze.co...nina-banner.png): failed to open stream: no suitable wrapper could be found in /home/differen/public_html/app/design/frontend/athlete/default/template/olegnax/slideshow/athlete.phtml on line 74
    2014-08-19T00:03:43+00:00 ERR (3): Warning: getimagesize(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/differen/public_html/app/design/frontend/athlete/default/template/olegnax/slideshow/athlete.phtml on line 78
    2014-08-19T00:03:43+00:00 ERR (3): Warning: getimagesize(http://differenze.co...nino-banner.png): failed to open stream: no suitable wrapper could be found in /home/differen/public_html/app/design/frontend/athlete/default/template/olegnax/slideshow/athlete.phtml on line 78
    2014-08-19T00:04:23+00:00 ERR (3): Warning: file_get_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/differen/public_html/app/code/community/Gimmie/WidgetPage/Model/Source/Countries.php on line 5
    2014-08-19T00:04:23+00:00 ERR (3): Warning: file_get_contents(https://raw.github.c.../countries.json): failed to open stream: no suitable wrapper could be found in /home/differen/public_html/app/code/community/Gimmie/WidgetPage/Model/Source/Countries.php on line 5
    2014-08-19T00:04:23+00:00 ERR (3): Warning: Invalid argument supplied for foreach() in /home/differen/public_html/app/code/community/Gimmie/WidgetPage/Model/Source/Countries.php on line 6
    2014-08-19T00:04:23+00:00 ERR (3): Warning: array_merge(): Argument #2 is not an array in /home/differen/public_html/app/code/community/Gimmie/WidgetPage/Model/Source/Countries.php on line 13


    exception.log:

    2014-08-19T00:03:42+00:00 ERR (3):
    exception 'Exception' with message 'This letter cannot be sent.' in /home/differen/public_html/app/code/local/Aschroder/SMTPPro/Model/Email/Template.php:40
    Stack trace:
    #0 /home/differen/public_html/app/code/core/Mage/Core/Model/Email/Template.php(509): Aschroder_SMTPPro_Model_Email_Template->send('luizstyle@hotma...', NULL, Array)
    #1 /home/differen/public_html/app/code/core/Mage/Newsletter/Model/Subscriber.php(523): Mage_Core_Model_Email_Template->sendTransactional('newsletter_subs...', 'support', 'luizstyle@hotma...', NULL, Array)
    #2 /home/differen/public_html/app/code/core/Mage/Newsletter/Model/Subscriber.php(356): Mage_Newsletter_Model_Subscriber->sendConfirmationRequestEmail()
    #3 /home/differen/public_html/app/code/core/Mage/Newsletter/controllers/SubscriberController.php(64): Mage_Newsletter_Model_Subscriber->subscribe('luizstyle@hotma...')
    #4 /home/differen/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Newsletter_SubscriberController->newAction()
    #5 /home/differen/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('new')
    #6 /home/differen/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
    #7 /home/differen/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
    #8 /home/differen/public_html/app/Mage.php(683): Mage_Core_Model_App->run(Array)
    #9 /home/differen/public_html/index.php(87): Mage::run('', 'store')
    #10 {main}



    valeu!
  • Abraao Marques Moderador Global
    Luizstyle,

    eu estava com esse mesmo problema. Instalei o módulo do SMTP PRO e não resolveu o meu problema. Eu consegui resolver fazendo uma pequena alteração no sistema de envio nativo do magento. Acessa o link abaixo e verifica como fiz para resolver:

    http://4magento.com.br/falha-no-envio-de-email-no-magento/


    Um abraço!!!
  • Luizstyle,

    eu estava com esse mesmo problema. Instalei o módulo do SMTP PRO e não resolveu o meu problema. Eu consegui resolver fazendo uma pequena alteração no sistema de envio nativo do magento. Acessa o link abaixo e verifica como fiz para resolver:

    http://4magento.com.br/falha-no-envio-de-email-no-magento/


    Um abraço!!!

    Fala Abraao, beleza?

    Fiz esta mudança e mesmo assim não consegui enviar email.
    No meu caso não envia nenhum email, nem transacional, nem de newsletter e nem de nada.

    Tem mais algum lugar para mudar?

    Obrigado!
  • Abraao Marques Moderador Global
    Estava lendo o erro do arquivo exception.log, mas o erro informado ali é referente ao SMTP Pro. Depois que você fez essa alteração, antes de testar, você desabilitou o SMTP Pro? Se ele ainda estiver ativo, então o envio está sendo ainda por ele. Se estiver ativo, desative-o, atualize os índices do seu sistema e teste novamente.

    Testa e posta o resultado aqui!

    Um abraço
  • anderson Usuário

    Estava lendo o erro do arquivo exception.log, mas o erro informado ali é referente ao SMTP Pro. Depois que você fez essa alteração, antes de testar, você desabilitou o SMTP Pro? Se ele ainda estiver ativo, então o envio está sendo ainda por ele. Se estiver ativo, desative-o, atualize os índices do seu sistema e teste novamente.

    Testa e posta o resultado aqui!

    Um abraço
    Abraao, vc pode me ajudar, que modificação vc fez no magento para funcionar.... o site que vc citou não esta funcionando mais e eu to com este problema no meu magento, os emails nao chegam nem por localhost quanto smtp pro... vlw
Entre ou Registre-se para fazer um comentário.